Email correspondence issues
Incident Report for Netix
Resolved
Emails service was restored at approximately 19:30 on 21/02/2023. We believe any affected emails should also have processed through at this time. Due to this delay responses may be delayed until the backlog is processed.
Posted Feb 22, 2023 - 09:05 UTC
Investigating
We have been made aware of a potential issue with our emails. Netix generated emails are unaffected, however our colleagues' addresses are experiencing issues with sending/receiving emails. We are still contactable via phone or our support helpdesk.

We are investigating as a priority 1 issue.
Posted Feb 21, 2023 - 13:46 UTC